[파이썬] 특정 버전 패키지 설치

2020. 2. 29. 20:06개발/파이썬

오류 증상

아나콘다 최신 버전 설치 후 pyqt5 를 설치하는데 아래와 같이 오류가 생겼다. 

ERROR: spyder 3.3.6 has requirement pyqt5<5.13 

영어 그대로 PYQT5 버전이 5.13보다 적어야 하기 때문.

 

해결

5.13 보다 적어야 한다고 하면, 그 보다 낮은 버전을 설치해 주자 

아래처럼 "pip install pyqt5==5.12" 식으로 해보면 바로 될 경우가 있고 5.12 버전을 찾을 수 없는 경우 설치가능한 모든 리스트가 나오니 그 중에 하나를 골라서 해당 버전으로 설치하면 된다.

pip install pyqt5==5.12